Blog posts

Bio

Autodesk Server Security Upgrade: Impacts on Autodesk Desktop Subscription Products

As announced previously, on March 31, 2015, Autodesk will perform an upgrade to a security protocol that will enhance our ability to provide secure access to customers' Desktop Subscription software. This upgrade is in response to published information describing vulnerability in SSL 3.0, a communication protocol designed to provide security over computer networks. The vulnerability, called POODLE, is an industry-wide vulnerability affecting the SSL 3.0 protocol itself and is not specific to Autodesk products.

What is happening?

On March 31, 2015, Autodesk will disable SSL 3.0 on our Desktop Subscription authentication servers. After March 31, 2015, customers with Autodesk® Desktop Subscription 2014 and 2015 software who have not yet logged in for the first time will experience an error when they first log into any of their Desktop Subscriptions. The error will read, "Establish an Internet connection to continue." Subsequent attempts to log in will fail with the same message until the following action is taken.

Action Required by Customers

  • Autodesk® Desktop Subscription customers can download a hotfix to repair this issue.  
  •  download this hotfix to avoid any issues. Learn more here.