• Blog posts

    Bio

    by Chris Turner

    I have seen this problem a few times over the years and more specifically have had this issue at two customers recently, when I have upgraded their Vaults from Vault 2013/2014 to 2015. One was Vault Workgroup and the other Vault Basic. It certainly baffled me a while, as I had not seen just DWG files from AutoCAD or Inventor not wanting to check in at all and pretty much hanging the applicatoion. All other file types were working fine as expected.

     

    I went down the whole route of hotfixes, checking the images were embedded correctly, disabling firewalls and anti-virus programs, securities, reinstalling Vault clients, Design Review etc etc.

     

    I then came across something in the Autodesk forums which was the solution to the problem and it solved both sites instantaneously! Thank you to them!

    http://forums.autodesk.com/t5/inventor-general-discussion/inventor-2014-dwg-will-not-check-in-to-vault/td-p/3941124

     

    The key to the problem was on the Server and had to do with a temporary file ‘UNDDACAD.ac$’.

    As per the Autodesk forum I suggest the following which certainly worked for me.

     

    1. On all ADMS’, examine the content of the ‘C:\Windows\Temp’ directory for ‘UNDDACAD.ac$’.
    2. Check the file date.  If it is much older than the installation date (or if you want to test this), proceed…
    3. Open a Command Prompt and Invoke IISRESET /STOP.
    4. Move ‘UNDDACAD.ac$’ out of the ‘C:\Windows\Temp’ directory.
    5. Invoke IISRESET /START.
    6. Test DWG check in again. The check in will generate a new current version of ‘UNDDACAD.ac$’.

     

    I hope this blog also helps others that have experienced this headache.

     

    Chris

     

    NOTE: I have found that when in a mixed CAD version environment, like some 2014 clients with some 2015 clients, the key is to create the UNDDACAD.ac$ file from the lower AutoCAD 2014 version.