Error: Application Unable To Start Correctly

Zen Admin
Zen Admin

Question

Issue:

When you start up AutoCAD 2015-based program, the following error message is displayed:

The application was unable to start correctly (0xc0000142). Click OK to close the application.

 

In some cases AutoCAD will not show this error and will simply not start and provides no error message 


The start up errors may reference LMU.exe, or in the event log refer to a crash of mshtml.dll

Answer

Causes:

 

Incorrectly registered DLL files, incompatible DLLs, or another program may be preventing AutoCAD from running. 
Possible conflicting software includes:

  • NVIDIA drivers
  • Beyond Trust "Trusted Desktop" btpload64.dll
  • Adobe Acrobat 9 Pro Extended acapture64.dll and acapture32.dll
  • Corrupted C++ installation

Solution:

 

For Adobe Acrobat 9, rename the following DLL files: 

C:\Windows\System32\acapture64.dll 
C:\Windows\SysWOW64\acapture32.dll 

Alternatively, you may uninstall the "Adobe Acrobat 9 Pro Extended 64-bit Add-On." On 32-bit systems, modify the Adobe Acrobat 9 program to not have the "Capture CAD Modules" installed. 

To help troubleshoot and determine what is conflicting with AutoCAD, use Microsoft's Auto runs utility.

1.      Download and install Auto runs.

2.      Start Auto runs.

3.      Start AutoCAD.

4.      Check AppInit tab in Auto runs window.

5.      Review the DLL files listed. Rename them one by one, testing the program start up after each change to try to isolate the problematic DLL.

For programs that lock the software, such as antivirus or other protection packages, contact the product manufacturer to see if exceptions can be created in the software.

If this is a C++ installation error, uninstall the C++ modules on the system and reinstall. Autodesk installers ship with prerequisites in the extracted installation folders- not the installed program files folders. You can manually access the installers here on most machines:

C:\Autodesk\PROGRAM FOLDER NAME\3rdParty\x64\VCRedist
C:\Autodesk\PROGRAM FOLDER NAME\3rdParty\x86\VCRedist

Uninstall the redistributables and reinstall them from this location. 

A different program may incorrectly be switching a registry key from a 0 to a 1. Changing the value to 0 may help.
 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion \Windows\LoadAppInit_DLLs
http://msdn.microsoft.com/library/dd744762%28v=vs.85%29.aspx

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