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Introduction

What is the Job Server?
the Job server is a feature used to off-load visualization file publishing (dWF) from the engineering 
workstation during the check in process.  Publishing visualization files of large assemblies can slow 
the check in of designs.  by off-loading this process, users can quickly check in files and ensure 
consistent visualization file creation.  the Job server can also be used to synchronize properties 
after a lifecycle change has been invoked on a file.

How It Works

Components
the Job server consists of two components:

1. Job Queue - A list, or queue, of jobs submitted by clients (Inventor, AutoCAd, Vault, 
Autoloader) waiting to be processed.  this queue is stored in and managed by the Vault 
server.

2. Job Processor - is a separate application that reserves queued jobs and pulls them from the 
job server to process them. since the job processor is installed along with the vault client, any 
workstation with Autodesk Vault can be used to publish jobs.

Submitting a Job
Jobs are submitted to the job server when:

• A user checks in a file which needs a visualization file created.

• A user invokes an update View command inside of the Vault client application.

• Autoloader is used to load files into the vault and visualization files are needed.

• A status change occurs on a file and an updated visualization file is needed.

• A status change occurs on a file and properties need to be synchronized in the file.
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Enabling the Job Server
the Job server allows publishing jobs to be queued and processed at a later time. You must 
activate the Job server prior to sending any jobs to it for publishing.

Note: You must be an Administrator to enable the Job server. users logged in prior to the Job 
server being enabled must log in again to submit jobs.

1. select Tools > Administration in the Vault client application. 

2. In the Administration dialog, click the Visualization tab. 

3. select the enable Job server check box to activate the job server.

Job Server
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Managing the Job Server Queue
the Job server holds a list of jobs waiting to be processed.

1. select Tools > Job Queue. 

2. In the Job server Queue dialog, you can sort the jobs by Id, status, description, submitted 
date, or by whom they were submitted. 
 
Note: the Job server Queue dialog displays up to 1,000 jobs. A warning will appear if there 
are more than 1,000 jobs in the queue.  
 
right-click on the column heading to customize the layout and view of the queue.  
 
If you want to filter the list so that it only displays the jobs queued after a specific date and 
time, click the Queued After list and specify a date.

3. select a job that you want to modify and perform one of the following actions: 

• If you want to delete the job from the queue, click remove.

• If the job has an error status, click re-submit to reprocess the job. 

• If you want to remove the job processor from the task and leave the job in the queue, click 
reset to Queue. 
 
Note: this command is not on the toolbar by default. to add the command, click the 
toolbar list and select Add or remove buttons. 

• If you want to assign the task to the job processor on your workstation, click take 
ownership. 
 
Note: this command is not on the toolbar by default. to add the command, click the 
toolbar list and select Add or remove buttons.

4. Click Print to send the grid to the default printer. Click refresh at anytime to update the 
queue. 



4

Autodesk VAult

Job serVer

Job Server Details

this table describes the details of the Job server Queue dialog.

Detail Description

Job type the type of job that was submitted for processing. Visualization jobs display 
as Autodesk.Vault.dWF.Create {0} where {0} is the file extension.

submitted by displays the name of the user who submitted the job to the queue.

submitted date displays the date and time the job was submitted to the queue.

Job Processor displays the name of the computer that has taken the job from the queue for 
processing.

description displays more information about the job in the queue. this field will also 
display the dWF Create: filename.

status displays whether the job’s status is Pending, Processing, or error.

results displays information only if the job has an error status.
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Job Server Commands

this table describes the commands on the Job server Queue dialog.

Detail Description

Close Closes the Job server Queue dialog.

Queued After Filters the list by showing the first 1,000 jobs queued after the specified date 
and time.

refresh refreshes the queue.

re-submit reprocesses a job that has encountered an error. this button is only enabled 
when a job has been placed in error state.

reset to 
Queue

removes the reservation of a job by the job processor. 

Note: this command is not on the toolbar by default. to add the command, 
click the toolbar list and select Add or remove buttons.

transfer 
ownership

transfers ownership of the job’s reservation to the current user’s job 
processor.

When a site that has reserved jobs is deleted, or a back up is performed but 
the information is restored to a different site, the pending jobs are deleted 
from the queue. this feature allows administrators to claim ownership for 
processing the job before it is deleted. 

Note: this command is not on the toolbar by default. to add the command, 
click the toolbar list and select Add or remove buttons

Print Prints the current queue grid to the default printer.
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From the Job Processor dialog, a user can pause and resume processing, set the vault user 
account that is used to process jobs, and determine the types of jobs that the Job Processor 
creates and publishes. 

Access the application by selecting Start > All Programs > Autodesk > Autodesk Data 
Management > Tools > Autodesk Job Processor for Vault [Edition]. 

Note: the Job Processor can be configured to launch automatically when the workstation is started 
in the Job Processor’s Administration menu.

Job Processor Details

Detail Description

Job Id displays the number of the job currently being processed.

Job type displays a description of the job being processed.

description displays more information about the job in the queue.

status displays the current state of the Job Processor.

status bar displays the server name and the user account.

Processing 
start time time at which the Job Processor began working on a job.

Job Processor
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Configuring the Job Processor

Logging into the Job Processor

the first time you access the job processor, you must specify the user name, password, and server 
name. the job processor will remember these login credentials each time you log in until changed 
through the Administration menu. 

1. on the workstation where you want jobs to be processed, select Start > All Programs  > 
Autodesk > Autodesk Data Management  Tools > Autodesk Job Processor for Vault 
[Edition] to launch the Job Processor application.

2. select Administration > Settings to display the settings dialog. 

3. enter the Vault user Name and Password of the user for this workstation.

4. specify the server from which you want the job processor to pull jobs for publishing.

5. Click ok to save your changes and close the settings dialog.

6. select File, resume to log in to the specified server. 
Note: select File, Pause at any time to halt the job processor and prevent it from processing 
any new jobs. If the job processor is in the middle of processing a job, it will finish the job first. 

Configuring the Job Processor to start automatically

1. on the workstation where you want jobs to be processed, select Start > All Programs   > 
Autodesk > Autodesk Data Management Tools > Autodesk Job Processor for Vault 
[Edition] to launch the Job Processor application.

2. select Administration > Start on Windows Logon. the Job Processor will launch whenever 
the user logs into to Windows. 
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Viewing job types

You can view the types of jobs that the Job Processor handles by accessing the Job types dialog. 

1. on the workstation where you want jobs to be processed, select Start > All Programs > 
Autodesk > Autodesk Data Management > Tools > Autodesk Job Processor for Vault 
[Edition] to launch the Job Processor application.

2. select Administration > Job Types to display the Job types dialog. If the workstation does 
not have the necessary information to process a particular type of job, that type of file is 
unchecked.

the ability for a Job Processor to handle a particular type of job is based on the application(s) 
installed on the workstation to process the job.

Job Types

Type Required Application

dWF creations of ipt, iam, idw, ipn Autodesk Inventor

dWF creations of dwg dWG trueView

sync Properties of iam, ipt, idw, ipn None

sync Properties of dwg None

sync Properties of dot, doc, xls, xlt, 
xla, ppt, pot, ppa, mpp, mpt, vsd, vst Microsoft office

sync Properties of docx, dotx, xlsx, 
xltx, xlax, pptx, potx, ppax, mppx, 
mptx, vsdx, vstx

None

the job types a workstation can process are indicated by a check next to the type in the Job types 
dialog.
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Managing Job Types

Managing the job types to be processed by a workstation is done by editing the Job Processor 
configuration file JobProcessor.exe.config.  this file is found in the <install dir>\Autodesk\Vault 
[edition]\explorer\ directory.

1. open the file with Notepad.

2. Find the jobHandlers section.

3. Comment out the line that contains the handler you do not want the workstation to process. 
use <!-- handler --> to comment out the line.

4. save the file and restart the Job Processor.  Check the Job types dialog to verify that the job 
type no longer appears.

Managing Check Period

by default, the Job Processor checks the server for a new job every 10 minutes.  this time can be 
adjusted by editing the JobProcessor.exe.config file.

1. open the file with Notepad.

2. Find the appsettings section.

3. edit the line that has <add key=”PeriodInMinutes value=”10” /> to the desired time. (minimum 
value of 1)

4. save the file and restart the Job Processor.
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Job Processor Logs

the Job Processor logs all jobs in the event Viewer Application log on the workstation.  this log can 
be useful when troubleshooting failed or incomplete jobs.

Multi-site Support

the Job server will support multi-site environments by logging into a specific server and only 
processing jobs that are associated with that server.  In the illustration below, any job processor that 
logs into site b will only process jobs that are at site b.  the same happens for Job Processors in 
site A.
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Job Processor Licensing

the Job Processor consumes one Vault server license during the time it connects to the server 
to reserve a job.  the Job Processor is not continuously logged into the Vault server during the 
processing of a job and the Vault server license it acquired is released.

If a Job being processed requires Inventor, an Inventor license is consumed while it is processing 
the  job and released when the job has completed.

Scheduling the Job Processor

use the Windows task scheduler to configure when and how often the Job processor starts. You 
must be logged in with a Windows user account to schedule this task.

1. open the Windows task scheduler.

2. browse to the JobProcessor.exe in the <install dir>\Autodesk\Vault [edition]\explorer\ directory.

3. Configure the frequency and time to start the Job Processor.

4. save the task.

Note: be sure to configure the account setting prior to the scheduled task starting the first time.  
this only needs to be set once and the Job Processor will use this account each time it runs.

the Job Processor can also be started when a user logs into Windows.  this is done by selecting 
“start on Windows log in” in the Administration menu of the Job Processor dialog.
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Submitting a Job
Jobs can be submitted to the Job server for processing during the check in process, during the 
change of lifecycle state, when loading files with Autoloader or while performing an update View in 
the client application.

In the Check-in dialog, select the settings button and select send to Job server in the Visualization 
Attachment option section.

to synchronize properties in a lifecycle state transition, check the box next to synchronize 
properties and update view using Job server in the transition dialog.
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to use the Job server in the client application: 

1. select a file and then select the arrow next to the update button.  

2. In the menu that appears, select Queue update.  

3. select the update button.   
Note: this setting will remain constant and every time you select the update button, the Job 
server will be used to create the visualization file.

to use the Job server with multiple files at once, select all files in the grid, then select Actions > 
Update View > Queue Update.
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to use the Job server in the Autoloader, select Create Visualization Attachment then select using 
the Job server radio button.
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update dWF View in the Web client

the web client can also be used to update a visualization file.  use the Update visualization 
file feature to re-publish visualization files that are currently out-of-date. the visualization file is 
published by the job server, so no additional utilities are required by the web client.

  

NOTE: the Update visualization file command is only available if the job server is enabled.

1. Click Update visualization file.

2. log into the vault.  the visualization file update request is sent to the job server. 
the job server confirms the request and adds the job to the queue.
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Example Workflow
Jobs can be submitted to the Job server for processing during the check in process, during the 
change of lifecycle state, while loading files with Autoloader or while performing an update View in 
the client application.

In the Check-in dialog, select the settings button and select send to Job server in the Visualization 
Attachment option section.


