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Technical Masterclass: 
Revit 2017 Tips and Tricks 

Presented by: Stuart Tanfield,  
BIM Technical Lead 
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Meet the Presenter 

Hello, my name is Stuart Tanfield, I hold the position of BIM Technical Lead at Cadline. I have spent 
over 10 years in the AEC industry, with a background in Mechanical & Electrical services, I took the 
unusual path of originally studying Architecture at University. It was at University where I was first 
exposed to the digital drawing world, and at the time, it appeared to be a completely alien topic to 
me. 

I spent the early part of my career getting to grips with AutoCAD and developing my skills within an 
M&E practice. This helped to provide a clear understanding of the software and how it can be 
practically applied to provide greater efficiencies. As I gained more experience I progressed to a 
more senior role in an M&E/ Architectural environment where I first encountered Revit, back in 
version 7.1. 

Having previously spent 5 years at Cadline as a product specialist, Revit and BIM was an integral part 
of my day to day role. Taking that knowledge away with me, I joined an M&E design team to aid in 
the implementation of all things BIM. This provided me with a real insight and great depth of 
working knowledge around the BIM environment, not just the Revit side, but also areas such as data 
management. 

I re-joined Cadline in November of 2014 and the knowledge I have gained has certainly helped to 
drive an efficient service around BIM strategies and provide clear guidance on the implementation 
and execution of the delivery of projects. Software and services are ever evolving and that is one of 
the best parts about my role, I get to see and work with these products every day, and there is 
clearly a defined path for the future. A path that will drive efficiencies and the ability to collaborate 
and improve performance within design teams and into the construction and management phases. 

Although BIM has been around for some time now, I believe we really are, in the overall scheme of 
things, still at the beginning of exploiting its potential. There are still lots of standards to be finalised 
and methods to be established and the way we work will develop and evolve. Of course BIM may 
now be the normal approach for many, there are still exciting times ahead as we now look to further 
engage with this new technology, and leverage its full potential. 

 

Stuart Tanfield 

BIM Technical Lead 
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Guidance notes: 

The use of Revit already provides us with lots of tools that may be a distinct improvement from that of our 

traditional 2D approach using AutoCAD. Much like AutoCAD, Revit has many areas, so knowing all these can 

prove to be very challenging, even for the most avid of users. I have chosen a few tips that I use in the 

industry that have helped to assist in my day-to-day role and found these particularly useful when trying to 

improve what I thought was a well-oiled system… 

View Templates: 

For standardisation it has to be View Templates. This tool assists in 

capturing view specific settings and then allows for application to 

other views. View templates could assist in the production of GA, Fire 

Strategy, Ventilation, Domestic Hot & Cold Water layout etc. In fact, I 

would suggest it is almost impossible to effectively produce a Revit 

project utilising MEP without these due to the varying disciplines and 

the graphical representations required. To initiate View Templates, 

simply set your view settings to suit your requirements, this might 

include view scale, visual styles, shadow settings etc. Once you have 

your view set, simply go to the View tab> View Templates> Create 

Template from Current View. Name your view template to something 

appropriate i.e. Cadline_Ventilation_Plan. 

Confirm the view settings, or adjust to suit your 

requirements and finally click OK. Now navigate 

to another view that you wish to apply the view 

settings to. Right Click over the view name> 

Apply Template Properties> Select the desired 

template name>Click OK.  

Double click to enter the view from your project 

browser to reveal the applied view template 

settings. 
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View Types: 

View Types follows on very nicely from View Templates. When starting a Revit project, it is not always 

desirable to have a template with pre-populated views, for a start you don’t always know how many levels 

you may need to deal with so often you will have to start by either deleting views or creating new ones. An 

efficient way of creating just the right number and types of views is to use View Types. View Types allow for 

the creation of views with a pre-defined View Template already assigned. In order to assign your view 

templates in this way you’ll 

need to do the following: 

Create your required View 

Templates. 

Go to the View Tab> Edit 

Types> Duplicate (Provide a 

suitable name i.e. 

Cadline_GA)> Select the 

appropriate View 

Template> Click OK in each 

of the dialogue boxes. You 

have now created a new 

floorplan View Type. 

 

 

In order to apply your View Type, go to the View Tab> Floorplan> 

Choose the View Type from the drop down> Untick the “Do Not 

Duplicate Existing Views”> hold CTRL and select all views to be 

created> Click OK. Check your project browser you should now see 

your new views all stored under a nice sub-heading. 
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Scope Boxes: 

Scope boxes are useful when you want to create a view which focuses 

specifically on one area of the building within multiple views. This is 

particularly useful if want to show an area right the way through the 

building levels, i.e. to view an atrium on levels 1-3, or to view a riser 

rising up through the building. 

To create a Scope Box, go to the View Tab>Scope Box. 

Provide the scope Box with a relevant name i.e. West Riser, and define 

an appropriate height.  

 

 

 

 

 

 

Now define the scope box area by drawing a rectangle. Once the Scope Box has been created it will need to 

be applied to the view. To do this simply scroll down in the properties dialogue box until you reach Scope 

Box, Click the end of the blank space and select the appropriate Scope Box from the drop down. The scope 

box will now be applied to the view you are in. You can subsequently apply the scope box to multiple views 

thereafter. 
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Shaft Opening – Symbolic Lines: 

When indicating a shaft opening, often an area that is overlooked is the ability to add symbolic linework. 

  

During the sketch mode, select “Symbolic Lines”. Draw your required lines, and click the Green Tick. Your 

opening will now be created along with 2D representational linework. 

 

Model Selection: 

Often, accidentally dragging linked files can cause problems, especially with new users. The Revit Status Bar 

offers users some useful tools to avoid these types of mishaps. You will find these tools on the bottom right 

hand corner of the Revit interface. There are three tools on this Tool Bar which become particularly useful. 

The first is the “Select Links” option. This will omit any linked files from a selection window. 

The second is the “Select Pinned Elements” tool. This will omit any pinned elements from any selection 

window. 

Lastly, the “Select Elements by Face” tool allows the user to 

select their Revit objects by a face rather than an edge. 
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Sketchy Visual Styles 

Many users are unaware of Revit’s ability to produce 

“Sketchy” linetype outputs. In order to present your 

models like this, you simply need to know where the 

settings are.  

Select the Visual Styles icon at the bottom of your screen. 

Next, select “Graphic Display Options…” 

In the next dialogue window, expand the Sketchy Lines 

section, now tick Jitter and Extension. Adjust the slider to 

your required settings (this may take a bit of trial and error 

to get just the right settings). Click Ok and the sketchy lines will have 

been applied to your view. You can also tick the Ambient Shadows 

dialogue for additional visual enhancements. These settings can be 

applied to 2D and 3D views. 
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Quick Tips: 

MEP and phasing: 

Refrain from using Phasing with MEP system family components. If you are required to demolish any part of 

your system as part of any phasing, this will result in your system becoming unidentified. Personally I would 

utilise Filters to accomplish this task instead. 

Project Browser: 

The project browser can be your best friend or your worst enemy. In order to be able to find the views you 

are looking for quickly, make sure you have organised your project browser sufficiently. Without doing this, 

life can become an uphill struggle. 

Orient to View: 

A quick way to apply a section box to your 3D model is to use the Orient to View function. Right click over 

the View Cube>Orient to View>Sections>select a section. This will cut your 3D model exactly where you have 

placed your 2D section marker. 

Arrow Heads: 

Don’t feel limited by the arrow head selections available by default. You can create any arrow head you like. 

Simply go to Manage>Additional Settings>Arrow Heads. Duplicate the current arrow head and begin to 

customise a new one. 

Copy Items to Multiple Floors: 

To quickly copy components from one level to another select the item you want to copy. Click Modify>Copy 

to Clipboard>Paste Aligned to selected Levels>Pick the appropriate levels (Hold CTRL to pick multiple 

levels)>Click OK. 

Copy from Linked File: 

In some instances, you may want to copy components from a linked file into your own. In the drawing area 

of a view of the host model, move the cursor over the element in the linked model. Press Tab until the 

element to copy is highlighted, and click to select it. Navigate to the Modify menu>Copy to Clipboard>Paste 

Aligned to Same Place. 
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Working Sections: 

Creating lots of sections to check your model as you develop your design can create lots of unwanted and 

unnecessary views. In order to limit the number of sections you create, simply create a few working sections. 

These can be used to check your model by simply dragging them to the area that requires checking. Once 

you have finished with them, you can simply delete them from your project. 

Phases and Phase Filter Naming: 

When using Phases and Phase Filters, it makes sense to name the phase filter so it is the same as the Phase 

to which it should be applied. This makes life easy when you are applying both of these to a view and avoids 

any confusion. 

Section Extents: 

Often when creating a section, the view extents pass beyond the point you want to view. Often users zoom 

out of the view to find the section extents arrow to drag it back to a more appropriate position. To save time 

zooming, view the Far Clipping Offset parameter and change this to 1m. This will make the extents arrow far 

easier to select without the need for zoom adjustment. 

Shortcuts: 

You can create your own shortcuts in Revit. All shortcuts are two letters. Navigate to the View Tab>User 

Interface>Keyboard Shortcuts. Now search for the command you want to apply a shortcut to. Enter the two 

letter combination and Click Assign. Click Ok. Now you can test the shortcut. 

Linked file underlay: 

To fade any linked models to help increase visibility of your own models, navigate into Visibility 

Graphics>Revit Links>Tick the Underlay Box>Click Ok. The linked files will now appear lighter. 

Resetting project co-ordinates: 

At times, project co-ordinates change. This can lead to a lot of fuss and often causes chaos. Often the easiest 

way to overcome any change like this is to reset the project co-ordinates back to their default position. The 

most effective and straight forward way to achieve this is to simply import an empty default Revit file, 

acquire the co-ordinates and hey presto. Now you can begin to import the new file with the new co-ordinate 

position. 

 


